Report Generation in Traffic Data Online
Incident Report for Miovision Technologies Inc
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 10:57 EST
Investigating
Please be advised that we are currently experiencing issues with report generation in TDO which prevents users from downloading new reports. We are actively investigating the issue and working diligently to a resolution. Datalink report generation is operational.
Posted Nov 30, 2022 - 09:56 EST