DataLink Outage
Incident Report for Miovision Technologies Inc
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 10:06 EST
Investigating
It has been brought to our attention that users are unable to access DataLink. We are actively investigating the situation. We apologize for the inconvenience and hope to provide an update soon.
Posted Nov 28, 2022 - 08:59 EST
This incident affected: Datalink (Login, Traffic Data Search, Traffic Data Requests, Travel Time Reports, Traffic Data Reports, Connected Devices, Insights).