TrafficLink unavailable
Incident Report for Miovision Technologies Inc
Resolved
This incident has been resolved.
Posted May 29, 2020 - 12:11 UTC
Update
We are continuing to investigate this issue.
Posted May 29, 2020 - 01:26 UTC
Investigating
We are currently investigating this issue.
Posted May 28, 2020 - 19:05 UTC
This incident affected: TrafficLink (Login, Map View, Insights, API).