Datalink Performance Issues
Incident Report for Miovision Technologies Inc
Resolved
This incident has been resolved.
Posted Nov 06, 2019 - 19:52 UTC
Investigating
We are currently investigating this issue.
Posted Nov 06, 2019 - 17:50 UTC
This incident affected: Datalink (Login, Traffic Data Search, Traffic Data Requests, Travel Time Reports, Traffic Data Reports, Connected Devices).