Miovision One Outage

Incident Report for Miovision Technologies Inc

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 13:07 EDT

Monitoring

Dear Valued Customers,

Miovision One functionality has been restored. We will continue to closely monitor performance for any further issues. We appreciate your patience and continued support.
Posted Oct 16, 2025 - 08:32 EDT

Investigating

Dear Valued Customers,

It has been brought to our attention there has been a number of applications within the Miovision One platform erroring out and or taking extended periods of time to load. We are actively investigating and diligently working towards uncovering a root cause and resolution. Please continue to follow this page for further updates.
Posted Oct 16, 2025 - 08:20 EDT
This incident affected: Miovision One (Map View, Video/Video recall, Intersection Monitoring, Performance, Mobility Reports).