Intermittent issues with DataLink
Incident Report for Miovision Technologies Inc
Resolved
This incident has been resolved.
Posted Mar 28, 2019 - 18:37 UTC
Investigating
We are investigating an issue where DataLink pages are intermittently unavailable. Updates will be posted here. If you encounter an issue accessing a page, please wait several minutes and refresh your browser.
Posted Mar 28, 2019 - 13:31 UTC
This incident affected: Datalink (Login, Traffic Data Search, Traffic Data Requests, Travel Time Reports, Traffic Data Reports, Connected Devices).