Authentication unavailable
Incident Report for Miovision Technologies Inc
Resolved
This incident has been resolved.
Posted Dec 19, 2019 - 21:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2019 - 19:18 UTC
Investigating
We are currently investigating this issue.
Posted Dec 19, 2019 - 18:51 UTC
This incident affected: TrafficLink (Login), Datalink (Login), and TrafficDataOnline (Login).