Datalink Degraded Performance
Incident Report for Miovision Technologies Inc
Resolved
This incident has been resolved.
Posted May 07, 2021 - 14:32 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 07, 2021 - 00:09 UTC
Identified
Some users may experience difficulty accessing Datalink due to an overload of concurrent usage. We have identified the problem and are testing a fix. We will update when fix has been implemented.
Posted May 06, 2021 - 17:55 UTC
This incident affected: Datalink (Login, Traffic Data Search, Traffic Data Requests, Travel Time Reports, Traffic Data Reports, Connected Devices).