Customer Support phone lines are currently down
Incident Report for Miovision Technologies Inc
Resolved
This incident has been resolved.
Posted Jul 18, 2019 - 17:32 UTC
Update
We are continuing to investigate this issue.
Posted Jul 18, 2019 - 17:32 UTC
Investigating
We are currently investigating the issue. In the meantime, you can reach Customer Support by emailing support@miovision.com or by using the chat feature in DataLink or TrafficLink.
Posted Jul 18, 2019 - 15:50 UTC
This incident affected: Support (Phone System).