Datalink Down

Incident Report for Miovision Technologies Inc

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 18:07 EDT

Monitoring

A fix has been implemented and functionality has been restored to Datalink. We will continue to monitor the site.

Thank you for your patience and we apologize for any inconvenience.
Posted Jul 03, 2025 - 17:47 EDT

Investigating

We are currently investigating an issue preventing access to our Datalink website. We are working on restoring functionality as soon as possible but we will provide an update as soon as we can. Thank you for your patience.
Posted Jul 03, 2025 - 15:57 EDT
This incident affected: Datalink (Login, Traffic Data Search, Traffic Data Requests, Travel Time Reports, Traffic Data Reports, Connected Devices, Insights, Continuous Counts).