Miovision One - Mobility Reports Outage

Incident Report for Miovision Technologies Inc

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 07:17 EDT

Monitoring

We have implemented a fix and users can now load the Mobility Report data. We will continue to monitor and will provide further updates if needed.

Thank you.
Posted Apr 08, 2026 - 13:58 EDT

Investigating

Dear Valued Customers,

When accessing Mobility Reports in Miovision One, users may encounter error messages when attempting to view data. We are actively investigating the root cause and are working diligently toward a resolution. Please continue to monitor this page for further updates.

We appreciate your patience and continued support.
Posted Apr 08, 2026 - 12:08 EDT
This incident affected: Miovision One (Mobility Reports).