Outage with third party service

Incident Report for Miovision Technologies Inc

Resolved

This incident has been fully resolved. MiovisionOne and TraffickLink are fully operational.
Posted Mar 20, 2025 - 09:35 EDT

Monitoring

We have an update regarding an incident affecting Snowflake, a service that our MioivsionOne and TrafficLink websites rely on for some of their functionality. Snowflake has reported that the incident was resolved at 19:45 UTC on March 19th.

While the Snowflake team was resolving this issue, the following services on the Miovision end were impacted:

ATSPMs (data may have been delayed or unavailable)

Any Chart or Dashboard (including Detection Clearance, Mobility Reports, Performance and Safety Monitoring)

Important Note: Data is not lost. The temporary inability to save data to Snowflake means that some information may have been delayed in appearing in the affected services. Once our systems catch up to the restoration of service, all data will be correctly reflected.

Thank you for your patience and feel free to contact support@miovision.com if you have any questions.
Posted Mar 19, 2025 - 17:36 EDT

Identified

We have been notified that there is an incident Snowflake which our MioivsionOne and TrafficLink websites use for some of its functionality. While that issue is being resolved by the Snowflake team, the following services are impacted on Miovisions end:
ATSPMs (from TrafficLink)
Any Chart/Dashboard in MioOne (Detection Clearance, Mobility Reports, Performance and Safety Monitoring)

Data is not lost, but is unable to be saved to Snowflake and will eventually be correct after their service is restored.

Thank you for your patience and feel free to contact support@miovision.com if you have any questions.
Posted Mar 19, 2025 - 15:19 EDT
This incident affected: Miovision One (API, Performance, Mobility Reports) and TrafficLink (API, TrafficLink Insights).