Miovision.com and Miovision.eu down

Incident Report for Miovision Technologies Inc

Resolved

The incident has been resolved and users can now access miovision.com and miovision.eu
Posted Jun 13, 2025 - 07:36 EDT

Investigating

We are currently investigating an issue with miovision.eu website and are working on restoring functionality as soon as possible.

Service to miovision.com has been restored.

Please note that our other websites such as miovision.one, trafficdataonline.com, datalink.com, my.miovision.com and help.miovision.com have remained operational.

Thank you for your patience.
Posted Jun 12, 2025 - 17:11 EDT

Identified

The issue with our miovision.com and miovision.eu websites may be related to an issue with Cloudflare. They are reporting that services are beginning to recover.

Cloudflare has their own status page open here: https://www.cloudflarestatus.com/incidents/25r9t0vz99rp
Posted Jun 12, 2025 - 16:18 EDT

Investigating

We are currently investigating an issue with our miovision.com and miovision.eu websites and are working on restoring functionality to these sites as soon as possible.


Please note that our other websites such as miovision.one, trafficdataonline.com, datalink.com, my.miovision.com and help.miovision.com are operational.

Thank you for your patience.
Posted Jun 12, 2025 - 15:01 EDT
This incident affected: Website (Miovision.com, Miovision.eu).