Issue Retrieving Pedestrian Data in Mobility Reports

Incident Report for Miovision Technologies Inc

Identified

Our Engineering teams are currently investigating a technical issue impacting Miovision One organizations. We have identified a disruption where pedestrian data is temporarily unavailable or failing to generate within Mobility Reports.

This issue appears to be strictly isolated to pedestrian metrics within Mobility Reports. Vehicle data, telemetry, and all other live platform features continue to operate normally.

We are actively working to isolate the root cause and restore the data flow.

We appreciate your patience as we investigate this issue. We will provide further updates on this page as additional information as it becomes available.

Best regards,

Miovision Customer Support Team
Posted May 25, 2026 - 12:16 EDT
This incident affects: Miovision One (Mobility Reports).