Datalink unavailable
Incident Report for Miovision Technologies Inc
Resolved
This incident has been resolved.
Posted Jan 27, 2020 - 19:19 UTC
Investigating
We are currently investigating this issue.
Posted Jan 27, 2020 - 17:49 UTC
This incident affected: Datalink (Login, Traffic Data Search, Traffic Data Requests, Travel Time Reports, Traffic Data Reports, Connected Devices).