Standard Turnaround
Incident Report for Miovision Technologies Inc
Resolved
There is no longer a risk to turnaround for any study.
Posted Jan 16, 2019 - 18:52 UTC
Monitoring
Due to high upload volumes, standard turnaround studies may be published 4-6 hours past due this week. There is no impact to priority (24- and 48-hour) turnaround studies.
Posted Jan 15, 2019 - 18:41 UTC
This incident affected: Services (Turnaround).