Datalink Invitation Emails Failing to Send

Incident Report for Miovision Technologies Inc

Resolved

The issue affecting the delivery of Datalink invitation emails has been successfully resolved. All invitation emails are now being sent and received as expected for both new sign-ups and organization invites. Thank you for your patience during this time.
Posted Oct 10, 2025 - 10:21 EDT

Monitoring

The issue affecting the delivery of Datalink invitation emails has been fixed. All new invitation emails are now being sent and received as expected. We will continue to monitor the system to ensure stability.

Thank you for your patience as we worked to resolve this.
Posted Oct 10, 2025 - 09:51 EDT

Investigating

We are currently experiencing an issue with invitation emails to Datalink (https://datalink.miovision.com/) not being sent out. This is affecting both entirely new users attempting to sign on, as well as existing users being invited onto other organizations they are not currently part of as they need to follow the email link.

We are actively working to correct the problem. For the most up-to-date information on this incident, please check our Status Page: https://status.miovision.com/

We thank you for your patience.
Posted Oct 09, 2025 - 17:47 EDT
This incident affected: Datalink (Login).