Phone System Down
Incident Report for Miovision Technologies Inc
Resolved
This incident has been resolved.
Posted Mar 10, 2023 - 06:53 EST
Identified
It has been brought to our attention that our phone systems are currently down due to a fibre optic cut in close proximity to our office. Please contact us via email until a resolution has been met at support@miovision.com. We appreciate your patience as we work towards a resolution.
Posted Mar 09, 2023 - 16:26 EST
This incident affected: Support (Phone System).