Miovision One load times

Incident Report for Miovision Technologies Inc

Investigating

We have noticed that load times have increased once again for Miovision One and pages sometimes time out. We are continuing to investigate and will provide an update as soon as we can.

Thank you for your patience.
Posted Jun 26, 2026 - 08:56 EDT

Monitoring

Load times have improved for Miovision One and we will continue to monitor the situation.
Posted Jun 25, 2026 - 13:53 EDT

Investigating

We are currently investigating an issue where some users are experiencing longer than expected load times in Miovison One.

We thank you for your patience as look to resolve this as soon as possible.
Posted Jun 25, 2026 - 13:19 EDT
This incident affects: Miovision One (Login, Map View, API, Video/Video recall, Intersection Monitoring, Detection, Performance, Mobility Reports, Adaptive, Video Detection Configuration, Traffic Studies App, Continuous Safety Monitoring).