Unable to access parts of Miovision One

Incident Report for Miovision Technologies Inc

Resolved

The incident has been resolved.
Posted Jul 10, 2026 - 06:44 EDT

Monitoring

We have implemented a fix and users should be able to access the ITS applications in Miovision One. We will continue to monitor the situation and will provide updates if needed.
Posted Jul 09, 2026 - 12:14 EDT

Investigating

We are currently investigating an issue with organizations being unable to access ITS related applications in Miovision One. These apps include the following:
-Network Overview
-Intersection Monitoring
-Detection
-Performance
-Adaptive
-Continuous Safety Monitoring

We are actively working on restoring these pages and will provide an update as soon as we can. Our aplogies for any inconvenience this has caused and thank you for your patience.
Posted Jul 09, 2026 - 11:28 EDT
This incident affected: Miovision One (Map View, Video/Video recall, Intersection Monitoring, Detection, Performance, Mobility Reports, Adaptive, Video Detection Configuration, Continuous Safety Monitoring).